Get the publish field to work correctly in blog posts sites

By Michael Doyle posted 12-08-2011 14:03

  

The home page of the blog post site can sometimes fail to work with the publishing date.If it doesn't work or stops working the only way i have found to get it working again is to modify the errant page in Designer.  To solve this problem modify the page and put in a filter. You can do this by following these steps.

1.      Open up the blog site in SharePoint Designer

2.      Click on All Files in the left hand navigation pane

3.      Right click default.aspx and choose Edit File in Advanced Mode

4.      Click on the web part that shows the blog posts. The caption WebPartPages:XsltListViewWeb… should appear at the top of the web part. You may have to click around near the top of the web part to get this to show up.
 
5.      Once you have clicked on the right area, the ribbon at the top will change so that you see several options such as Filter, Sort & Group, Conditional Formatting, etc. Click on Filter.
 
6.      The Filter Criteria dialog box will show up. It should be empty.
 
7.      Under Field Name choose the Published field.
 
8.      Under Comparison choose the Less Than option.
 
9.      Under Value choose [Current Date]
 
10.   Save the page.
 
 
The blog posts should work now based upon the published date. This doesn’t take the time into consideration so remember that when publishing.


#SharePoint #blog #sharepoint #publish
0 comments
209 views